Troubleshoot common CMH issues

This article provides solutions to common issues you might encounter while using the Coveo Merchandising Hub (CMH).

Product attributes missing from rule creation interface

Issue

When configuring merchandising rules in the CMH (for example, ranking rules, filters, or synonyms), some product attributes may not appear in the attribute dropdown menu, even though they were indexed in your product source.

Cause

In the CMH, selectable attributes are scoped from the source’s products. This means that it doesn’t display all fields across the entire organization but only those detected in the products associated with the product source.

Resolution

If you notice that a specific attribute is missing when creating rules, and you know it’s indexed in your source, map the corresponding metadata to a Coveo field to ensure that it’s recognized.

Product listing page product count discrepancy

Issue

There’s a discrepancy between the following:

  • The number of products shown on the Product Listing Page (PLP) (for example, 13 items).

  • The number displayed under the Products metric (for example, 0 items) for the same listing page in the Product listing manager in the CMH.

Cause

This is expected behavior. The Products metric in the CMH is generated from Coveo Analytics data. If no requests have been recorded for the listing page, the metric may temporarily display 0 products even though the PLP contains items.

Resolution

To update the product count, access the listing page directly in your storefront. This action triggers an event associated with the page. After an hour or two, the Products metric should reflect the accurate product count shown on the PLP.

Product images visible in preview but not in metrics

Issue

In the CMH, product images may be visible in the Preview tab of a search term, PLP, or recommendation slot, but fail to appear in the Product metrics section.

Cause

The inconsistency is due to the different product resolution mechanisms used by the CMH’s preview and metrics:

  • The CMH preview pulls product data directly from the product source, using data contained in the ec_thumbnails field.

  • The metrics section resolves products via the ec_product_id configured in the catalog configuration.

If the unique identifier selected in your catalog configuration to map to the ec_product_id field doesn’t match the value mapped to permanentid in your source, the metrics endpoint is unable to resolve the product properly. As a result, the product’s metadata can’t be retrieved, even though it exists and is correctly indexed.

Resolution

To resolve the issue, ensure that the unique identifier configured in your catalog configuration matches the field mapped to permanentid in your source.

  1. Review the catalog configuration:

    1. Access the Catalogs (platform-ca | platform-eu | platform-au) page of the Coveo Administration Console, and then select the desired catalog entity.

    2. Under Configuration, open your catalog configuration.

    3. On the Standard fields tab, ensure that the metadata key that uniquely identifies products is correctly associated with the ec_product_id field.

  2. Align source mappings:

    1. Access the Sources (platform-ca | platform-eu | platform-au) page of the Coveo Administration Console, and then click the source indexing your product data.

    2. In the Action bar, click Mappings.

    3. Under Field, locate permanentid and verify which metadata key is mapped to it. The metadata key mapped to permanentid must match the unique identifier selected in your catalog configuration to map to ec_product_id. If there’s a mismatch, map the metadata key to the permanentid field.

See Map commerce fields for a complete guide on field mappings in the context of Coveo for Commerce.