Cannot See Values When Using an Existing Field in a Facet

Symptoms

When adding a facet in a search page, you choose a field that you know exists in your index:

However, the facet appears empty.

You have also ensured that you search interface where you insert your facet returns results that have values for this specific field.

Cause

This issue can be caused by a few things.

Pro and Enterprise editions only

Your field may not be configured as a facet, meaning that it cannot be used in a facet.

Free edition only

If your field was newly created, it may not yet be in the schema for the Coveo Search API.

If you are using a Date field or a Numerical field with a large value, the Coveo for Salesforce Free edition may not be able to return the appropriate results.

Resolution

Pro and Enterprise editions only

You need to make your field available as a facet in the Coveo Cloud (see Add or Edit Fields).

Free edition only

When you have just created the field, you need to wait for the schema to be updated (see Using Custom Fields With the Coveo for Salesforce Free Edition).

When using a Date field or a Numerical field with a large value, you are encouraged to remove the facet.