Can't See Values When Using an Existing Field in a Facet

Symptoms

When adding a facet in a search page, you choose a field that you know exists in your index and confirmed that this field is indexed in the Coveo Platform.1

1: When using the Coveo for Salesforce Free edition (deprecated) you must instead verify that the field exists in Salesforce.

However, the facet appears empty.

You have also ensured that you search interface where you insert your facet returns results that have values for this specific field.

Cause

Usually, the issue is caused because your field is not set as a facet, meaning that it can’t be used in a facet.

Free edition only - Deprecated

If your field was newly created, it may not yet be in the schema for the Coveo Search API.

If you’re using a Date field or a Numerical field with a large value, the Coveo for Salesforce Free edition (deprecated) may not be able to return the appropriate results.

Resolution

You need to make your field available as a facet in the Coveo Cloud (see Add or Edit a Field).

Free edition only - Deprecated

When you have just created the field, you need to wait for the schema to be updated (see Using Custom Fields With the Coveo for Salesforce Free Edition).

When using a Date field or a Numerical field with a large value, you’re encouraged to remove the facet.

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