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Troubleshooting
- Free Edition General Troubleshooting Steps
- Search Interface Does Not Return the Expected Results in the Coveo for Salesforce Pro or Enterprise Edition
- Enabling the Interface Editor in Your Salesforce Organization
- Coveo Search Page Fails to Load After Upgrade
- Insight Panel Refuses to Display
- Unable to Install the Coveo Lightning Component for Community Cloud
- Something Went Wrong Message When Selecting a Value in the Created By Facet
- Error When Adding or Accessing Coveo Components in a Lightning Community
- Error While Performing JWT Flow for the Requested User When Using Customer Community or Portal User With the Coveo for Salesforce Free Edition
- Filtering on NetworkScope Returns UnsupportedQueryExpressionException
- Getting a MALFORMED\_SEARCH Error When Selecting a Tab With the Coveo for Salesforce Free Edition
- Cannot See Values When Using an Existing Field in a Facet
- Unknown Page for the Current Site Configuration Error With Coveo Lightning Components
- Coveo Object Unavailable in Lightning Component
- The Feature is Not Activated for Your Organization
- The Search Token is Invalid in the Health Check Page
- An Unexpected Error Has Occurred In the Coveo Health Check Page After Deleting Coveo Cloud Organization
- Uncaught-DOMException-Failed-to-read-the-'responseText'-property-from-'XMLHttpRequest' Error Message When Using a Component
- Infinite Loading When Trying to Preview a Document in a Quick View
- Access Token Update Required
Uncaught-DOMException-Failed-to-read-the-'responseText'-property-from-'XMLHttpRequest' Error Message When Using a Component
Coveo for Salesforce 3.16 (August 2018)
Symptoms
When the CoveoQuickview
component is used in a Lightning component with an API version over 40, you might encounter the following error message:
Uncaught DOMException: Failed to read the 'responseText' property from 'XMLHttpRequest': The value is only accessible if the object's 'responseType' is '' or 'text' (was 'document')
Cause
Salesforce Lightning Locker is activated on Lightning components with API versions over 40 and the default CoveoQuickview
is not compliant with Lightning Locker. (see [Coveo for Salesforce Overview(/en/1104/)).
Resolution
You should replace the invalid CoveoQuickview
component with the CoveoSalesforceQuickview
component, which is compliant with Salesforce Lightning Locker.
- In Setup, search for and select Visualforce Component.
With Salesforce Lightning | With Salesforce Classic |
---|---|
Under Platform Tools, select Custom Code > Visualforce Components. | Under Build, select Develop > Visualforce Components. |
- Next to your component, click Edit.
- Search for
CoveoQuickview
and replace it withCoveoSalesforceQuickview
.