Coveo for Sitecore 5 is now available!

Supported Sitecore Versions and Dependencies

Supported Sitecore Versions

The table below lists the minimum versions of Coveo for Sitecore 4.0 and 4.1 required for the supported Sitecore releases.

Coveo for Sitecore 4.0 supports Sitecore versions up to 8.2 update 6 only. For Sitecore versions between 8.2 update 7 and 9.3 inclusively, you need a Coveo for Sitecore 4.1 version that supports it or, better yet, a Coveo for Sitecore 5 release (see Coveo for Sitecore 5: Supported Sitecore Versions and Dependencies).

Not sure which version of Coveo for Sitecore you’re using? See Finding Your Coveo for Sitecore Version.

Coveo for Sitecore 4 has reached its lifecycle bug fix end date. No further releases of Coveo for Sitecore 4.0 or Coveo for Sitecore 4.1 are planned. Sitecore 9.3 is the last version supported by Coveo for Sitecore 4.1.

To continue benefiting from the latest Coveo for Sitecore enhancements and for support of more recent Sitecore versions, consider upgrading to Coveo for Sitecore 5.

Sitecore version Update Revision Supported by Coveo since Known issues
9.3 003498 4.1.735.153
9.2 002893 4.1.734.71

Rule Set Editor filtering and boosting, usually available to Enterprise Cloud licensees, isn't available in Sitecore 9.2 XM topologies, due to Sitecore not supporting the Rules Engine in these topologies.

9.1 1 002459 4.1.733.137 Rule Set Editor filtering and boosting, usually available to Enterprise Cloud licensees, isn't available in Sitecore 9.1 XM topologies, due to Sitecore not supporting the Rules Engine in these topologies.
9.1 001564 4.1.733.137 Rule Set Editor filtering and boosting, usually available to Enterprise Cloud licensees, isn't available in Sitecore 9.1 XM topologies, due to Sitecore not supporting the Rules Engine in these topologies.
9.0 2 180604 4.1.414.9
9.0 1 171219 4.1.286.9
9.0 171002 4.1.224.6
8.2 7 180406 4.1.414.9 An issue with Sitecore prevents the Experience Editor to save a page when a legacy UI component field defines rules.
8.2 6 171121 4.0.1639.3
4.1.224.6
An issue with Sitecore prevents the Experience Editor to save a page when a legacy UI component field defines rules.
8.2 5 170728 4.0.1606.9
4.1.184.19
An issue with Sitecore prevents the Experience Editor to save a page when a legacy UI component field defines rules.
8.2 4 170614 4.0.1547
4.1.82.12
An issue with Sitecore prevents the Experience Editor to save a page when a legacy UI component field defines rules.
8.2 3 170407 4.0.1461
4.1.82.12
An issue with Sitecore prevents the Experience Editor to save a page when a legacy UI component field defines rules.
8.2 2 161221 4.0.895
4.1.82.12
An issue with Sitecore prevents the Experience Editor to save a page when a legacy UI component field defines rules.
8.2 1 161115 4.0.895
4.1.82.12
An issue with Sitecore prevents the Experience Editor to save a page when a legacy UI component field defines rules.
8.2 160729 4.0.704
4.1.82.12
An issue with Sitecore prevents the Experience Editor to save a page when a legacy UI component field defines rules.
8.1 3 160519 4.0.222
4.1.82.12
8.1 2 160302 4.0.171
4.1.82.12
8.1 1 151207 4.0.171
4.1.82.12
An issue with Sitecore prevents the Experience Editor to save a page when a legacy UI component field defines rules.
8.1 151003 4.0.171
4.1.82.12
8.0 7 160115 4.0.171
4.1.82.12
An issue with Sitecore prevents the Experience Editor to save a page when a legacy UI component field defines rules.
8.0 6 151127 An issue with Sitecore prevents the Experience Editor to save a page when a legacy UI component field defines rules.
8.0 5 150812
8.0 4 150621
8.0 3 150427
8.0 2 150223
8.0 1 150121
8.0 141212
7.5 2 150212 4.0.171
4.1.82.12
7.5 1 150130
7.5 141003
7.2 6 160123 4.0.171
4.1.82.12
7.2 5 151021
7.2 4 150408
7.2 3 141226
7.2 2 140526
7.2 1 140314
7.2 140228

Supported Browsers and Operating Systems

Coveo for Sitecore 4.0 fully supports the same browsers as the JavaScript Search Framework V1 (see Supported Browsers - Coveo JavaScript Search Framework) and the same operating systems as Sitecore itself (see Sitecore Compatibilty Table).

Other browsers and operating systems may have limited compatibility which will result in unexpected rendering issues of the Coveo search components.

There are known issues with Internet Explorer 11:

Coveo JavaScript Search Framework v2

Coveo for Sitecore 4.1 is delivered with the second version of Coveo’s open source JavaScript Search Framework (see Coveo JavaScript Search Framework - Reference Documentation).

You can learn more about what you can do with the JavaScript Search Framework in the developers documentation (see Get Started with the JavaScript Search Framework).

Coveo JavaScript Search Framework v1

Coveo for Sitecore 4.0 is delivered with Coveo’s open source JavaScript Search Framework v1 (see Coveo JavaScript Search Framework - Reference Documentation).

See your version release notes to know which version of the framework is included in your setup (see Coveo for Sitecore 4.0: Release Notes).

You can learn more about what you can do with the JavaScript Search Framework in the developers documentation (see Get Started with the JavaScript Search Framework).

Recommended Articles