-
Most Common Issues
- Inactivity Timeout During Rebuild
- Coveo Sort Components Are Stacked in an MVC Search Page
- Security Provider Error Something Went Wrong on the Server
- Problem Accessing the Coveo Admin Service
- Problem Loading the Ninject Assembly
- Empty Strings are not Allowed Exception Occurring When Specifying Creator-Owner Permissions
- Internal Server Error When Querying the REST Service
- Editing the Properties of a Coveo Search MVC Component Freezes the Page Editor in IE11
- Error with ID NO\_DOCUMENT\_INDEXED
- Error or Document Not Found Page After Rebuilding the Indexes
- Problem Registering Search Page Events in Sitecore Analytics Database
- Sitecore Items Do Not Get Automatically Indexed
- Sitecore 8.0 Session is not Initialized Exception
- The Indexing Manager Is Reporting an Error
- Configuration Wizard error - Unable to add the certificate to the Root store. Access is denied.
- Slow Queries in a Coveo-Powered Search Page
- Issue in IE During Admin Service Configuration with the Configuration Wizard
- High Memory Usage While Rebuilding Indexes
- Root Element of a Crawler for a Coveo Index is Invalid
- 404 Errors on Coveo Usage Analytics Search Events
- HTML Version of Indexed Items Are Showing an Error Page
- Coveo-Powered Search Page Fails to Load After Upgrade
- Diagnostic Page Error - Invalid cast from System.String to Coveo.Framework.Configuration.SecurityConfiguration
- Including a Search Box with OmniboxResultList Results in Cannot read property addEventListener of null Error
- Timeout While Expanding Sitecore Security Provider
- NullReferenceException on Tracking.Current When Executing a Request for a Quick View
- Coveo for Sitecore Security Cache Refresh Issues
- How to Modify the Coveo for Sitecore Security Provider Refreshing Parameters
- 403 Forbidden Error When Calling YourSitecoreSite/coveo/rest
- Getting log4net Errors When Attempting to Browse Sitecore Pages
- The Sitecore Security Provider ABC has encountered a fatal exception class CSP FatalException Unable to connect to Sitecore
- No User has been Provided for the Search Request
- Opening Sitecore Indexing Manager Returns a 405 (Method Not Allowed) Error
- Secured Admin Service - Could Not Establish Trust Relationship for the SSL/TLS Secure Channel with Authority Localhost
- Hive Components - Inserting an Example Search Page Results in No Renderings
Error with ID NO_DOCUMENT_INDEXED
Symptom
When looking at the CES index logs (from the CES Administration Tool > Logs > Index or directly in the file C:\CES7\Logs\Index_YYYY-MM-dd.log
), you may see errors similar to the following ones:
212285218277549773|IMPORTANT|2014-12-12|16:25:44|0|Rebuild on source Coveo_web_index - MachineName-InstanceName has been requested by domain\username.||||||||||||||||
212285218277549774|IMPORTANT|2014-12-12|16:25:44|0|Rebuilding the source Coveo_web_index - MachineName-InstanceName.|||||Sitecore Search Provider||||Coveo_web_index - MachineName-InstanceName|SUCCESS|||3514|32352||
212285218277549775|WARNING|2014-12-12|16:25:44|0|Since the live monitoring is currently enabled, the rebuild won't do anything.|||||Sitecore Search Provider||||Coveo_web_index - MachineName-InstanceName|SUCCESS|||3514|32352||
212285218277549776|ERROR|2014-12-12|16:25:44|0|Error with ID 'NO_DOCUMENT_INDEXED': No documents were crawled.|||||Sitecore Search Provider||||Coveo_web_index - MachineName-InstanceName|NO_DOCUMENT_INDEXED|||3514|32352||
212285218277549777|ERROR|2014-12-12|16:25:44|0|Queue Error: No documents were crawled.|||||Sitecore Search Provider||||Coveo_web_index - MachineName-InstanceName|SUCCESS|||3514|32352||
212285218277549778|ERROR|2014-12-12|16:25:44|0|... Coveo.CES.CustomCrawlers.CrawlerFatalException: No documents were crawled.|||||Sitecore Search Provider||||Coveo_web_index - MachineName-InstanceName|SUCCESS|||3514|32352||
212285218277549779|ERROR|2014-12-12|16:25:44|0|... at Coveo.CES.CustomCrawlers.CustomCrawler.RefreshThread()|||||Sitecore Search Provider||||Coveo_web_index - MachineName-InstanceName|SUCCESS|||3514|32352||
212285218277549780|IMPORTANT|2014-12-12|16:25:44|0|The source Coveo_web_index - MachineName-InstanceName rebuild was stopped.|||||Sitecore Search Provider||||Coveo_web_index - MachineName-InstanceName|SUCCESS|||3514|32352||
Cause
The Coveo Search Provider is starting the Coveo Enterprise Search (CES) source before pushing Sitecore items to be indexed. Starting a source is done by enabling Live Monitoring and starting a rebuild of the source. When Live Monitoring is enabled on a source, the rebuild operation is expected to do nothing but set the source state to idle. After a rebuild operation, CES verifies if documents were indexed and throws the NO_DOCUMENT_INDEXED
error when there was none.
Resolution
This is the expected behavior for the Queue crawler used by Coveo for Sitecore sources. You can ignore this error.