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Most Common Issues
- Inactivity Timeout During Rebuild
- Coveo Sort Components Are Stacked in an MVC Search Page
- Security Provider Error Something Went Wrong on the Server
- Problem Accessing the Coveo Admin Service
- Problem Loading the Ninject Assembly
- Empty Strings are not Allowed Exception Occurring When Specifying Creator-Owner Permissions
- Internal Server Error When Querying the REST Service
- Editing the Properties of a Coveo Search MVC Component Freezes the Page Editor in IE11
- Error with ID NO\_DOCUMENT\_INDEXED
- Error or Document Not Found Page After Rebuilding the Indexes
- Problem Registering Search Page Events in Sitecore Analytics Database
- Sitecore Items Do Not Get Automatically Indexed
- Sitecore 8.0 Session is not Initialized Exception
- The Indexing Manager Is Reporting an Error
- Configuration Wizard error - Unable to add the certificate to the Root store. Access is denied.
- Slow Queries in a Coveo-Powered Search Page
- Issue in IE During Admin Service Configuration with the Configuration Wizard
- High Memory Usage While Rebuilding Indexes
- Root Element of a Crawler for a Coveo Index is Invalid
- 404 Errors on Coveo Usage Analytics Search Events
- HTML Version of Indexed Items Are Showing an Error Page
- Coveo-Powered Search Page Fails to Load After Upgrade
- Diagnostic Page Error - Invalid cast from System.String to Coveo.Framework.Configuration.SecurityConfiguration
- Including a Search Box with OmniboxResultList Results in Cannot read property addEventListener of null Error
- Timeout While Expanding Sitecore Security Provider
- NullReferenceException on Tracking.Current When Executing a Request for a Quick View
- Coveo for Sitecore Security Cache Refresh Issues
- How to Modify the Coveo for Sitecore Security Provider Refreshing Parameters
- 403 Forbidden Error When Calling YourSitecoreSite/coveo/rest
- Getting log4net Errors When Attempting to Browse Sitecore Pages
- The Sitecore Security Provider ABC has encountered a fatal exception class CSP FatalException Unable to connect to Sitecore
- No User has been Provided for the Search Request
- Opening Sitecore Indexing Manager Returns a 405 (Method Not Allowed) Error
- Secured Admin Service - Could Not Establish Trust Relationship for the SSL/TLS Secure Channel with Authority Localhost
- Hive Components - Inserting an Example Search Page Results in No Renderings
THIS IS ARCHIVED DOCUMENTATION
Configuration Wizard error - Unable to add the certificate to the Root store. Access is denied.
Symptoms
When installing the Coveo for Sitecore package and checking Use a secure Admin Service in the Configuration Wizard, you may get the following error:
Causes
To be able to import the specified certificate, Coveo for Sitecore needs to impersonate the administrator account that you specified, so the error may have one of the following causes:
- The user account that you specified may not be a member of the local Administrators group.
- If UAC is enabled, importing the certificate requires that the administrator account also has elevated privileges, which is impossible while impersonating a user.
Resolution
- Make sure that the user account that you specified is a member of the local Administrators group.
- If UAC is enabled, you need to temporarily disable it by using this method.
- Log into the Sitecore server.
- Open the Registry Editor (
regedit.exe
). - Expand the following key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
- Modify the value of
EnableLUA
to0x00000000
. - Restart the server.
- Coveo for Sitecore (April 2017) Reconfigure the Admin Service through the Sitecore Control Panel, see Configuring the Admin Service After Install.
- For earlier releases, reinstall the Coveo for Sitecore package using the Sitecore Installation Wizard. There shouldn’t be any error anymore.
- Using the Registry Editor, modify the value of
EnableLUA
to0x00000001
. -
Restart the server.
Lowering the User Account Control Settings slider to Never notify isn’t enough, as UAC is still enabled when you do so.
What's Next for Me?