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Most Common Issues
- Inactivity Timeout During Rebuild
- Coveo Sort Components Are Stacked in an MVC Search Page
- Security Provider Error Something Went Wrong on the Server
- Problem Accessing the Coveo Admin Service
- Problem Loading the Ninject Assembly
- Empty Strings are not Allowed Exception Occurring When Specifying Creator-Owner Permissions
- Internal Server Error When Querying the REST Service
- Editing the Properties of a Coveo Search MVC Component Freezes the Page Editor in IE11
- Error with ID NO\_DOCUMENT\_INDEXED
- Error or Document Not Found Page After Rebuilding the Indexes
- Problem Registering Search Page Events in Sitecore Analytics Database
- Sitecore Items Do Not Get Automatically Indexed
- Sitecore 8.0 Session is not Initialized Exception
- The Indexing Manager Is Reporting an Error
- Configuration Wizard error - Unable to add the certificate to the Root store. Access is denied.
- Slow Queries in a Coveo Search Page
- Issue in IE During Admin Service Configuration with the Configuration Wizard
- High Memory Usage While Rebuilding Indexes
- Root Element of a Crawler for a Coveo Index is Invalid
- 404 Errors on Coveo Usage Analytics Search Events
- HTML Version of Indexed Items Are Showing an Error Page
- Coveo Search Page Fails to Load After Upgrade
- Diagnostic Page Error - Invalid cast from System.String to Coveo.Framework.Configuration.SecurityConfiguration
- Including a Search Box with OmniboxResultList Results in Cannot read property addEventListener of null Error
- Timeout While Expanding Sitecore Security Provider
- NullReferenceException on Tracking.Current When Executing a Request for a Quick View
- Coveo for Sitecore Security Cache Refresh Issues
- How to Modify the Coveo for Sitecore Security Provider Refreshing Parameters
- 403 Forbidden Error When Calling YourSitecoreSite/coveo/rest
- Could not Load File or Assembly log4net, Version=1.2.11.0, culture=neutral
- The Sitecore Security Provider ABC has encountered a fatal exception class CSP FatalException Unable to connect to Sitecore
- No User has been Provided for the Search Request
- Opening Sitecore Indexing Manager Returns a 405 (Method Not Allowed) Error
- Secured Admin Service - Could Not Establish Trust Relationship for the SSL/TLS Secure Channel with Authority Localhost
- Hive Components - Inserting an Example Search Page Results in No Renderings
Timeout While Expanding Sitecore Security Provider
This issue affect Coveo for Sitecore 4.0 On-Premises
Symptoms
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Your secured items are not searchable.
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In the Index Browser, the secured items have nothing in their effective combined permissions.
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In the CES Console or System logs, you see the following error:
Permission 11111111111111111111111111111111111111 needs update because Allowed sid 111111 has not been updated once yet
Cause
The coveo_sitecoreadministrators
group is very large and cannot expand within the allowed 5 minutes.
Resolution
Change the MaxAllowedTimeWithoutProgress
on the Sitecore Security Provider to something higher. The default is 300 seconds, which is about 5 minutes.
- Open the Coveo Administration Tool.
- Navigate to Configuration > Security >Security Provider >[Sitecore Security Provider on Your Server]
- In the Parameters section:
- If parameter
MaxAllowedTimeWithoutProgress
exists, enter a value high enough to cover the security expansion time. - If parameter
MaxAllowedTimeWithoutProgress
does not exist:- Click Add Parameter.
- In the Name column, enter
MaxAllowedTimeWithoutProgress
. - In the Value column, enter a value high enough to cover the security expansion time.
- If parameter
- Click Apply Changes.