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Failed to Reactivate the Organization Message in Command Center

Coveo for Sitecore 4.1 (August 2018)

Symptoms

In the Command Center, you see the Your Coveo Cloud Organization Is Inactive dialog box.

After clicking the Reactivate button, you get the following message.

Failed to reactivate the organization. Please use the Coveo Cloud Admin Console to reactivate your organization.

Cause

The Coveo Cloud API Key template for Sitecore does not currently include the Edit privilege over the Organization item. Since reactivating a Coveo Cloud organization requires this privilege, the action is unauthorized.

Resolution

In order to reactivate the organization through Coveo for Sitecore, the Edit privilege is required on the Organization item in the API Key configuration. If you are an administrator of your Coveo Cloud organization, you have full privileges over all organization API keys.

  1. Access the Coveo Cloud administration console.
  2. In the top portion of the page, select your organization from the drop-down menu.
  3. In the lower left portion of the page, select the Status > Click to reactivate.

This solution fixes the problem immediately. However, you are encouraged to modify the API key used inside Sitecore to fix the issue permanently.

  1. Log in to the Coveo Cloud administration console with an administrator account.
  2. In the top portion of the page, select your organization from the drop-down menu.
  3. In the menu on the left, under Organization, select API Keys.
  4. In the list of API keys, select the API key used in Sitecore.
  5. Click Edit.
  6. Under Privileges > Organization, set the Access Level of the Organization privilege to Edit.