Failed to Reactivate the Organization Message in Command Center
Failed to Reactivate the Organization Message in Command Center
Symptoms
In the Command Center, you see the Your Coveo Cloud Organization Is Inactive dialog box.
After clicking Reactivate, you get the following message.
Failed to reactivate the organization. Please use the Coveo Cloud Admin Console to reactivate your organization.
Cause
The Coveo Cloud API Key template for Sitecore doesn’t currently include the Edit privilege over the Organization item.
Since reactivating a Coveo organization requires this privilege, the action is unauthorized.
Resolution
To reactivate the organization through Coveo for Sitecore, the Edit privilege is required on the Organization item in the API Key configuration.
If you’re an administrator of your Coveo organization, you have full privileges over all organization API keys.
Logging in to the Coveo Administration Console reactivates the organization. However, you’re encouraged to modify the API key used inside Sitecore to fix the issue permanently.
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Access the Coveo Administration Console.
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In the header, select your organization.
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In the menu on the left, under Organization, select API Keys.
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In the list of API keys, select the API key used in Sitecore.
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Click Edit.
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Under Privileges > Organization, set the
Access Levelof theOrganizationprivilege toEdit.