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Known Issues
- An Index Should Be Configured for Database web Error Is Preventing the REST Service from Loading
- Cannot insert the value NULL into column ID, table INSTANCE_HOSTNAME_Core.dbo.Properties column does not allow nulls. INSERT fails.
- Coveo for Sitecore Not Properly Replicating the Sitecore Permission Model
- ERROR Error in FileWatcher Internal Buffer Overflow While Installing Coveo for Sitecore
- ERROR Exception while handling event Sitecore.ContentSearch.Events.IndexingFinishedEvent, Index MY_INDEX was not found
- Error in the Experience Profile After Installing Coveo for Sitecore
- Failed to Reactivate the Organization Message in Command Center
- Field Is No Longer Indexed in the Sitecore Items
- Handler CoveoSearchEndpoint has a bad module ManagedPipelineHandler in its module list
- Items in Different Languages Are Not Automatically Indexed or Updated When Language Fallback Is Enabled
- Metadata Duplicated Keys are Producing Warnings in the Log Browser
- Missing Valid xDB License
- Multi-Value Field - Migrating from On-Premises to Cloud Version
- Opening the Experience Explorer Sets the Static Context to 'Master'
- Prebinding Isn't Applied to Elements Within a Searchbox Container
- Publishing Multi-Language Sitecore Items Leads to a Large Amount of Files Being Indexed
- Sitecore 8.0+ Error When Saving a Coveo-Powered Search Page Using the Sitecore Rule Engine
- Sitecore 8.2 With WFFM Refuses to Start After Installing Coveo for Sitecore
- Sitecore.ContentSearch.SitecoreItemCrawler.IsAncestorOf(Item item) error
- Slow Initial Rebuild Time Caused By The ExcludeCoveoDataSourceItems Processor
- Solr - Error When Initializing Coveo When Side-by-Side with Solr Is Enabled
- Solving the Conflict Between Keys from Dynamic Placeholder Modules and Coveo Dynamic Placeholders
- The Experience Editor for Non-Default Language Page Fails to Load When Using Coveo for Sitecore Hive
- The RouteData must contain an item named 'controller' error with SXA
- Two Instances of the Same Search Page Component Have Been Added on a Page but Only One is Initialized
- Unexpected Token < When Editing Page With SXA Components in Experience Editor
- Send Analytics to Sitecore Component Not Working in Sitecore 9
- Exception When Trying to Switch Organization
- Issues When the Core Database Is Disabled on Content Delivery Servers
- Content Database 'master' Not Found on a Content Delivery Server
- Coveo Analytics Events Are Not Logged in Sitecore 9.1 Analytics
- Ajax Error 500 When Using Special Characters in a Query
Coveo for Sitecore Not Properly Replicating the Sitecore Permission Model
Coveo for Sitecore 4.0 (August 2018) Coveo for Sitecore 4.1 (September 2018)
Symptoms
You have the following permissions scenario:
- A document is allowed to anonymous users (i.e., publicly available).
- The document has a parent that denies access to a given role/user.
- The item is allowed to a specific user/role.
- You have not explicitly denied
read
access to theextranet/Anonymous
user anywhere in the Content tree on the path to the document.
The expected result is that the document appears in the search results for all users except for the members of the denied role/user. The actual result is that the document appears in the search results for all users.
This vulnerability affects Coveo for Sitecore 4.0 and 4.1.
Cause
Coveo for Sitecore isn’t properly replicating the Sitecore permission model for this specific scenario.
Resolution
The issue can be resolved by adding an additional security configuration in Sitecore (see Quick Fix). Coveo has also fixed the issue in releases of Coveo for Sitecore 4.0 and 4.1 (see Coveo Fixes).
Quick Fix
As a quick fix, you can obtain the valid Coveo for Sitecore permissions by denying Read
permissions for the extranet/Anonymous
user on any parent folder of the restricted item(s) in the Sitecore Content Tree.
- In the Content Editor, on the path to the restricted item(s), select a folder.
- Under the Security tab, select Assign.
- In the Assign Security Rights dialog, click Add.
- In the Add an Account dialog, select the Users radio button.
- Select the
extranet\Anonymous
user. Click OK. -
Configure the
Read
access rights as illustrated below. - Save your changes.
- Publish your changes.
- Rebuild your indexes.
Coveo Fixes
Coveo has prepared fixes for Coveo for Sitecore 4.0 and 4.1 clients. Follow the instructions provided below to update your specific Coveo software.
Coveo for Sitecore 4.0
The August 2018 version of Coveo for Sitecore 4.0 has been hotfixed to eliminate the issue.
- Upgrade to the August 2018 release of Coveo for Sitecore 4.0.
- Rebuild your indexes.
Coveo for Sitecore 4.1
The issue is corrected in the September 2018 version of Coveo for Sitecore 4.1.
- Upgrade to the September 2018 release of Coveo for Sitecore 4.1.
- Rebuild your indexes.