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Error in the Experience Profile After Installing Coveo for Sitecore
Error in the Experience Profile After Installing Coveo for Sitecore
Symptoms
In Sitecore 9.0+, when installing Coveo for Sitecore, the Experience Profile stops showing events and instead displays the An error occurred.
error message.
Cause
The issue is caused by custom processors that aren’t supported in xConnect.
Resolution
Removing the processors brings back the events:
- In your Sitecore instance folder, navigate to
App_Config \Modules\Coveo
. -
In the
Coveo.ExperienceProfile.config
file, replace the file content with the following code:<!-- Don't modify this configuration file. Instead, you should patch this file using Coveo.ExperienceProfile.Custom.config. --> <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:coveo="http://www.sitecore.net/xmlconfig/coveo/"> <sitecore coveo:require="!disabled"> <!-- Previous processors were removed due to an issue causing an error in the Experience Profile. Event Types sent from Coveo for Sitecore in xConnect won't be visible in the Experience Profile. --> </sitecore> </configuration>