No available organizations displayed when activating Coveo for Sitecore
No available organizations displayed when activating Coveo for Sitecore
Symptoms
When you try to activate Coveo for Sitecore, the Existing tab for Coveo organization selection is missing, even though the user who’s logged in to the Coveo Platform is a member of the Administrators group in an existing Coveo organization.
The Sitecore logs show the following errors after login attempts:
Exception System.InvalidOperationException: An error occurred when trying to create
a controller of type 'IndexesV1Controller'.
Make sure that the controller has a parameterless public constructor. --->
System.InvalidCastException: Invalid cast from 'System.String' to
'Coveo.Framework.Configuration.SecurityConfiguration'.
Exception System.ArgumentNullException: Precondition failed: The parameter
'm_CloudPlatformConfiguration' must not be null
Parameter name: m_CloudPlatformConfiguration
Cause
Sitecore network requests are routed through a proxy that may be blocking communications with the Coveo Platform. As a result, the system cannot retrieve the list of available organizations. To confirm that a proxy is affecting communication, configure Sitecore to use a Fiddler to trace outbound traffic.
Resolution
Update the proxy configuration to add Coveo Platform IP addresses to the allowlist.
Alternatively, stop routing Sitecore network requests through the proxy by setting the useDefaultWebProxy
attribute to false
in your <SITECORE_INSTANCE_ROOT>\Web.config
file.