Date facet range using custom date ranges returns no results

In this article

Symptoms

Using a Coveo Date Facet Range or Coveo Dynamic Date Facet Range rendering with custom date ranges yields no results when filtering on a range (though the range shows a non-zero count).

Cause

An issue was introduced in version 2.10107 of the JavaScript Search Framework which the affected Coveo for Sitecore renderings use.

Resolution

The issue has been resolved in the October 23, 2023 Coveo for Sitecore release.

Workaround

You can configure affected search pages to use version 2.10110 of the JavaScript Search Framework.

To use version 2.10110 of the JavaScript Search Framework in a search page

  1. Open the search page in the Experience Editor.

  2. Select the Coveo Search Resources rendering. It should be located at the bottom of the page.

  3. In the floating toolbar, select Edit the rendering’s data source. It should be the leftmost option in the toolbar.

  4. In the JavaScript Search Resources section, clear the Use local files for Coveo JavaScript Resources checkbox, if necessary.

  5. In the Coveo JavaScript Search Framework CDN Version field, enter 2.10110 and click OK.

  6. Validate that your search page date facet ranges now work properly in the Experience Editor.

  7. Publish your changes.