Index not found or initialized issues
Index not found or initialized issues
In this article
Symptoms
There may be many error messages appearing in the Sitecore logs.
Examples of error messages you may see:
"The provided index '{0}' was not found."
Exception System.ArgumentNullException: Precondition failed: The parameter 'FieldMap' must not be null
Parameter name: FieldMap
at Coveo.Framework.CNL.Precondition.NotNull(Object p_Parameter, String p_ParameterName)
at Coveo.Framework.Fields.CoveoFieldNameTranslator.TranslateToCoveoFormat(String p_SitecoreFieldName, Boolean p_UsePrefix)
at Coveo.AbstractLayer.FieldManagement.FieldsHandlerUtility.EnrichFieldInfoWithTranslatedFieldName(FieldInformation p_FieldInfo)
at Coveo.Framework.Collections.EnumerableExtensions.ForEach[T](IEnumerable`1 p_Enumerable, Action`1 p_Action)
at Coveo.AbstractLayer.FieldManagement.FieldsHandlerUtility.GetCompleteFieldConfigs(String p_IndexName)
at Coveo.AbstractLayer.FieldManagement.CachedFieldsHandlerUtility.<Invalidate>b__11_0()
Exception System.NullReferenceException: Object reference not set to an instance of an object.
at Coveo.SearchProvider.AbstractSearchIndexSummary.<get_NumberOfDocuments>b__42_1()
at Coveo.SearchProvider.AbstractSearchIndexSummary.TryPerformCallToIndexCommunication[T](Func`1 p_CallToIndexCommunication, T p_DefaultValue)
at Coveo.SearchProvider.AbstractSearchIndexSummary.<get_NumberOfDocuments>b__42_0()
at Coveo.SearchProvider.AbstractSearchIndexSummary.get_NumberOfDocuments()
at Coveo.SearchProvider.AbstractSearchIndexSummary.GetIndexStatistics()
at Coveo.Service.Api.IndexServiceBase.Indexes.IndexesServiceFetcher.ConvertToIndex(IProviderIndex p_ProviderIndex, IDictionary`2 p_IndexesDictionary)
at System.Linq.Enumerable.WhereSelectListIterator`2.MoveNext()
at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
at Coveo.Service.Api.IndexServiceBase.Indexes.IndexesServiceFetcher.GetCoveoIndexes()
Cause
The actual root cause for these errors often lies upstream. The resolution section below provides help on where to find the root cause in the logs.
Resolution
Error 1 may result from a Sitecore instance shutting down or starting up around the same time.
WARN Sitecore shutting down
WARN Shutdown message: HostingEnvironment initiated shutdown
INFO HttpModule is being initialized
INFO Sitecore started
Errors 2 and 3 may result from the indexes not being initialized upon installation of Coveo for Sitecore. Search for the following log messages and make sure no error occurred while the index was initializing.
INFO Initializing index "Coveo_master_index"...
INFO Initializing index "Coveo_web_index"...