Lightning component no longer loads after updating the server-side configuration

Symptom

After you update the server-side configuration, your Coveo Lightning component becomes unresponsive (for example, it fails to load).

Possible cause

Your JSON configuration is invalid (for example, it contains invalid characters).

Resolution

  1. In the Query Editor of the Salesforce Developer Console, run the following SOQL query:

    SELECT ID, CoveoV2__Configuration__c FROM CoveoV2__CoveoLightningSettings__c
  2. In the Query Results grid, access the CoveoV2__Configuration__c field.

  3. Use a JSON validator to validate your JSON configuration.

  4. Update your JSON configuration as required, and then click Save Rows to apply your changes.