Lightning component no longer loads after updating the server-side configuration
Lightning component no longer loads after updating the server-side configuration
In this article
Symptom
After you update the server-side configuration, your Coveo Lightning component becomes unresponsive (for example, it fails to load).
Possible cause
Your JSON configuration is invalid (for example, it contains invalid characters).
Resolution
-
In the Query Editor of the Salesforce Developer Console, run the following SOQL query:
SELECT ID, CoveoV2__Configuration__c FROM CoveoV2__CoveoLightningSettings__c
-
In the Query Results grid, access the
CoveoV2__Configuration__c
field. -
Use a JSON validator to validate your JSON configuration.
-
Update your JSON configuration as required, and then click Save Rows to apply your changes.