Issue opening the Diagnostic Page
Issue opening the Diagnostic Page
In this article
Sitecore 10
Symptoms
You have installed Sitecore SXA and have an issue opening the Coveo Diagnostic Page.
Cause
There’s an issue with the way the coveo_website
site is resolved in SXA.
Resolution
This issue was fixed in the February 15, 2023 release.
Workaround
-
Open
<SITECORE_INSTANCE_ROOT>\App_Config\Modules\Coveo\Coveo.Authentication.config
in a text editor. -
Locate the
<federatedAuthentication>
element. -
Just above the
<federatedAuthentication>
element, add the following block.<!-- SXA handles site resolving differently. With this added setting, the coveo_website will be properly resolved when needed. --> <experienceAccelerator> <siteResolving> <site name="coveo_website" resolve="before" /> </siteResolving> </experienceAccelerator>
The beginning of the file should now be as follows:
<!-- Do not modify this configuration file. Instead, you should patch this file using a Coveo.Authentication.Custom.config file. --> <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:role="http://www.sitecore.net/xmlconfig/role/" xmlns:set="http://www.sitecore.net/xmlconfig/set/"> <sitecore role:require="Standalone or ContentDelivery or ContentManagement"> <!-- SXA handles site resolving differently. With this added setting, the coveo_website will be properly resolved when needed. --> <experienceAccelerator> <siteResolving> <site name="coveo_website" resolve="before" /> </siteResolving> </experienceAccelerator> <federatedAuthentication type="Sitecore.Owin.Authentication.Configuration.FederatedAuthenticationConfiguration, Sitecore.Owin.Authentication">
-
Save your changes.