Timeout While Expanding Sitecore Security Provider
Timeout While Expanding Sitecore Security Provider
This issue affects Coveo for Sitecore 4.0 On-Premises
Symptoms
-
Your secured items aren’t searchable.
-
In the Index Browser, the secured items have nothing in their effective combined permissions.
-
In the CES Console or System logs, you see the following error:
Permission 11111111111111111111111111111111111111 needs update because Allowed sid 111111 has not been updated once yet
Cause
The coveo_sitecoreadministrators
group is very large and can’t expand within the allowed 5 minutes.
Resolution
Change the MaxAllowedTimeWithoutProgress
on the Sitecore Security Provider to something higher. The default is 300 seconds, which is about 5 minutes.
-
Open the Coveo Administration Tool.
-
Navigate to Configuration > Security >Security Provider >[Sitecore Security Provider on Your Server]
-
In the Parameters section:
-
If parameter
MaxAllowedTimeWithoutProgress
exists, enter a value high enough to cover the security expansion time. -
If parameter
MaxAllowedTimeWithoutProgress
doesn’t exist:-
Click Add Parameter.
-
In the Name column, enter
MaxAllowedTimeWithoutProgress
. -
In the Value column, enter a value high enough to cover the security expansion time.
-
-
-
Click Apply Changes.