Failed to reactivate the organization message in Command Center
Failed to reactivate the organization message in Command Center
Symptoms
In the Command Center, you see the Your Coveo Organization Is Inactive dialog box.
After clicking Reactivate, you get the following message.
Failed to reactivate the organization. Please use the Coveo Cloud Admin Console to reactivate your organization.
Cause
Your current Coveo for Sitecore API keys don’t include the required privileges to reactivate a Coveo organization via Coveo for Sitecore.
Resolution
This issue is fixed in Coveo for Sitecore 5. However, if you’re upgrading from an older instance of Coveo for Sitecore 4, you may still encounter this issue.
To temporarily fix the issue
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Access the Coveo Administration Console (platform-ca | platform-eu | platform-au) as an administrator of your Coveo organization.
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In the header, select your organization.
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In the header, click , and then click Reactivate.
However, we recommend that you generate new Coveo for Sitecore API keys to fix the issue permanently.
To generate the API keys
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Access the Coveo Cloud Organization page of the Command Center at
http://<INSTANCE_HOSTNAME>/coveo/command-center/index.html#cloud-organization/
, where<INSTANCE_HOSTNAME>
is the name of your Sitecore instance. -
Click Log out.
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Click Log in.
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Authenticate in to the Coveo Platform as an administrator.
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On the Coveo Cloud Organization page, under the Existing tab, make sure the Coveo organization you want to generate the API keys for is selected.
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Click Apply and restart.
For ease of management and security purposes, we recommend that you delete your old Coveo for Sitecore API keys. You can perform this action from the API Keys (platform-ca | platform-eu | platform-au) page in the Coveo Administration Console. |