THIS IS ARCHIVED DOCUMENTATION

Failed to Reactivate the Organization Message in Command Center

Coveo for Sitecore 4.1 (August 2018)

Symptoms

In the Command Center, you see the Your Coveo Cloud Organization Is Inactive dialog box.

After clicking Reactivate, you get the following message.

Failed to reactivate the organization. Please use the Coveo Cloud Admin Console to reactivate your organization.

Cause

The Coveo Cloud API Key template for Sitecore doesn’t currently include the Edit privilege over the Organization item. Since reactivating a Coveo organization requires this privilege, the action is unauthorized.

Resolution

To reactivate the organization through Coveo for Sitecore, the Edit privilege is required on the Organization item in the API Key configuration. If you’re an administrator of your Coveo organization, you have full privileges over all organization API keys.

  1. Access the Coveo Administration Console.

  2. In the header, select your organization.

  3. Click the notification center (Bell icon), and then click Reactivate.

This solution fixes the problem immediately. However, you’re encouraged to modify the API key used inside Sitecore to fix the issue permanently.

  1. Access the Coveo Administration Console.

  2. In the header, select your organization.

  3. In the menu on the left, under Organization, select API Keys.

  4. In the list of API keys, select the API key used in Sitecore.

  5. Click Edit.

  6. Under Privileges > Organization, set the Access Level of the Organization privilege to Edit.