Supported Versions and Dependencies

Supported Dynamics Versions

Coveo for Dynamics supports:

  • Dynamics 9.0 (Dynamics 365) and newer versions
  • Dynamics 8.0 (Dynamics CRM 2016 Online), which was released in December 2015 (see Recent versions of Dynamics)

To determine which version you are using:

  1. Log in to your Dynamics instance.
  2. Click the cogwheel icon at the top right of the window.
  3. Click About. A new window opens and the version is written just below the header.

Supported Browsers

Coveo for Dynamics supports the following browsers:

Browser Supported versions Additional details
Internet Explorer

11, Edge

Known issue: Interface Editor Glitches in Internet Explorer 11
Google Chrome Latest stable
Mozilla Firefox Latest stable
Safari Latest stable Safari for Windows is not supported.

Coveo for Dynamics may work on other browsers but they are not officially supported by Coveo for Dynamics, resulting in possible unexpected rendering and behavior issues.

For browser compatibility with Dynamics 365 itself, see Supported web browsers and mobile devices.

Coveo JavaScript Search Framework

Coveo for Dynamics comes prepackaged with Coveo’s open-source JavaScript Search Framework. See the release notes for the JavaScript Search Framework version packaged with your Coveo for Dynamics version.