---
title: An index should be configured for database web error is preventing the reverse
proxy REST endpoint from loading
slug: '2148'
canonical_url: https://docs.coveo.com/en/2148/
collection: coveo-for-sitecore-v5
source_format: adoc
---
# An index should be configured for database web error is preventing the reverse proxy REST endpoint from loading
## Symptoms
When loading the reverse proxy REST endpoint, any Coveo Search component, or the Diagnostic page, you might get the following error:
```text
Exception: System.InvalidOperationException
Message: An index should be configured for database "web".
Source: Coveo.UIBase
at Coveo.UI.Helpers.SitecoreHelper.GetSearchIndex()
at Coveo.SearchProvider.Rest.SitecoreRestHttpHandler.GetSecurityProviderName()
at Coveo.SearchProvider.Rest.SitecoreRestHttpHandler.OnInitializeSettings()
at Coveo.Search.Api.Proxy.ProxyHttpHandler.OnInitialize()
at Coveo.Search.Api.Proxy.ProxyHttpHandler.EnsureInitialized()
at Coveo.Search.Api.Proxy.ProxyHttpHandler.ProcessRequest(HttpContext context)
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
```
## Cause
There are several causes for this issue.
You're encouraged to look through [Coveo Connect (Collaborate tab)](https://connect.coveo.com/s/collaborate) to identify your problem.
If this doesn't solve your issue, be aware that there's a Sitecore bug which binds new indexes configuration to item buckets.
Therefore, if the following setting value is false:
```xml
```
Then `ContentSearchManager.SearchConfiguration` is initialized as an empty one.
## Workaround
To solve the issue, enable item buckets in the Sitecore configuration:
```xml
```