-
Known Issues
- Infinite Loop at Authentication Step
- ExtensionRefinedQuery component does not support filters separated by commas
- Solution Installation Fails With LocalizedLabel Error
- QuerySummary Component Glitches When Complex Query Yields No Result
- Interface Editor Glitches in Chrome for Mac
- Interface Editor Glitches in Internet Explorer 11
- Failure When Populating Quick Create Form Fields With Long Values
- Coveo Read-Only Role Modifications Are Overridden Following a Coveo for Dynamics Update
- Take Note Component is Unresponsive in Expanded Insight Search Page
Failure When Populating Quick Create Form Fields With Long Values
This known issue affects Coveo for Microsoft Dynamics 365 1.1.180418.7 (April 2018) and later versions (see Coveo for Microsoft Dynamics 365 Release Notes).
Symptoms
When using the Quick Create component, you can use the formParameters
parameter to populate form fields with search result content (see ForDynamicsQuickCreate Component).
However, when trying to populate a field with a long value:
- In the regular user interface, the Quick Create form loads endlessly without any error message.
- In the Unified Interface, an error message is displayed on the problematic Quick Create form field.
- If you set options
openInNewWindow
totrue
anduseQuickCreateForm
tofalse
, the window that opens shows a400 Request Too Long
error.
You try to create a knowledge article and want its description to be the content of the @dycontent
search result field. Your component is therefore the following:
<div class='CoveoForDynamicsQuickCreate' data-entityId="knowledgeArticle" open-in-new-window="true" use-quick-create-form="false" data-form-parameters='{"title" : {"field": "@title"}, "description" : {"field": "@dycontent"}}'></div>
Since the content of the @dycontent
field is susceptible to be long, you might experience the failure described above.
Cause
This is a Dynamics limitation.
Resolution
There are two possible workarounds. They may however not solve the issue; the error messages Dynamics displays when you encounter this failure, if any, are usually generic, giving you no hint as to what to correct.
-
When using the Quick Create form, choose a Coveo field whose content does not exceed the Dynamics field character limit. For example, the
Description
field is limited to 155 characters. -
When using the
openInNewWindow
option, use a form field that accepts more characters if possible. For example, the knowledge base article creation form has aContent
field that is not limited to 155 characters.