User Cannot See the Coveo Components in Coveo for Salesforce

Symptoms

When your users try to access your Coveo components, they are unable to see them. This can happen either in a community after it was published or in a Visualforce page.

Cause

There are two main possible causes for this issue:

  • You have not granted your users access to your Coveo components.
  • When using Coveo for Salesforce prior to the May 2017 release (2.41), Lightning Locker is enabled.

Resolution

Depending on the cause of your issue, you need to follow these steps: