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Troubleshooting
- Search Interface Does Not Return the Expected Results
- Enabling the Interface Editor in Your Salesforce Organization
- Coveo-Powered Search Page Fails to Load After Upgrade
- Insight Panel Refuses to Display
- Unable to Install the Coveo Lightning Component for Community Cloud
- Error When Adding or Accessing Coveo Components in a Lightning Community
- Cannot See Values When Using an Existing Field in a Facet
- Unknown Page for the Current Site Configuration Error With Coveo Lightning Components
- Coveo Object Unavailable in Lightning Component
- The Feature is Not Activated for Your Organization
- Uncaught-DOMException-Failed-to-read-the-'responseText'-property-from-'XMLHttpRequest' Error Message When Using a Component
- Infinite Loading When Trying to Preview a Document in a Quick View
- Access Token Update Required
Error When Adding or Accessing Coveo Components in a Lightning Community
Coveo for Salesforce 2.41 (May 2017)
Symptoms
When adding or accessing a Coveo component in your Lightning community, you get the following error:
Action failed: CoveoV2$Base$controller$executeComponentInitilization [Cannot read property 'getComponentType' of undefined]
Cause
This issue arises when Lightning Locker is enabled in your community alongside Coveo components.
This is because Coveo doesn’t currently support the use of Lightning Locker in communities (see Coveo for Salesforce Overview).
Resolution
You need to disable Lightning Locker in your Lightning community.
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In Salesforce, in Setup, search for and select Critical Updates (Build > Critical Updates).
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Deactivate Lightning LockerService Security.
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Next to Enable Lightning LockerService Security, select Deactivate.
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On the Deactivate Update page, select Deactivate.
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